Bug 433 - nieprawidłowo zakodowany temat maili wysyłanych przez bugzillę
Summary: nieprawidłowo zakodowany temat maili wysyłanych przez bugzillę
Status: RESOLVED FIXED
Alias: None
Product: Bugzilla
Classification: Tłumaczenia oprogramowania
Component: Ogólne (show other bugs)
Version: nieokreślona
Hardware: Wszystkie Wszystkie
: P2 poważny
Assignee: Pawel Chmielowski
QA Contact: Roman Pszonka
URL:
Depends on:
Blocks: 216
  Show dependency treegraph
 
Reported: 2005-03-23 00:22 CET by Roman Pszonka
Modified: 2009-01-02 03:52 CET (History)
0 users

See Also:


Attachments

Description Roman Pszonka 2005-03-23 00:22:48 CET
żeby nie umknęło:
zakodowany temat powiadomienia (tutaj o błędzie 216) wygląda tak:
Subject: [=?UTF-8?B?QsWCxIVkCg==?= 216]
=?UTF-8?B?VMWCdW1hY3plbmllIEJ1Z3ppbGxpIDIuMTg=?=

niestety w środku jest znak nowego wiersza i w pine temat wyświetla się w dwóch
wierszach:
+   1003 Mar 22 bugzilla-daemon@biofizyka.agro.ar  (2839) [[UTF-8] Błąd
                                                                        216]
[UTF-8] Tłumaczenie Bugzilli 2.18
Comment 1 Roman Pszonka 2005-03-23 00:30:13 CET
w przypadku nowego błędu jest jeszcze gorzej, temat wyświetlany jest w 3
wierszach! dodatkowo część się nie dekoduje (pine 4.62)

źródło: 
Subject: [=?UTF-8?B?QsWCxIVkCg==?= 433]
   
=?UTF-8?B?Tm93eTogCg==?==?UTF-8?B?bmllcHJhd2lkxYJvd28gemFrb2Rvd2FueSB0ZW1hdCBtYWlsaSB3eXN5xYJhbnljaCBwcnpleiBi?=
 =?UTF-8?B?dWd6aWxsxJk=?=

wyświetla się jako:
+   1003 Mar 22 bugzilla-daemon@biofizyka.agro.ar  (3150) [[UTF-8] Błąd
                                                                        433]
[UTF-8] Nowy:
                                                                               
           =?UTF-8?B?bmllcHJhd2lkxYJvd28gemF
Comment 2 Pawel Chmielowski 2005-03-23 22:52:37 CET
W r11 umieściłem proponowaną poprawkę tego problemu. Zamiast ręcznie
przekodowywać tematy w róźnych miejscach, dodałem globalną funkcje która
przekodowuje maile tuż przed wysłaniem. Mam nadzieję że implementacja tego nie
spowoduje kolejnych kłopotów...
Comment 3 Roman Pszonka 2005-03-24 10:34:28 CET
już jest lepiej (dla błędu 216 tematy maili dekodują się poprawnie), ale wciąż
nie całkiem dobrze, choć nie wiem dokładnie dlaczego... w przypadku powiadomień
dla błędu 436, po "zdekodowaniu" tematu przez moje pine, wygląda on tak:
Subject:
=?UTF-8?Q?[B=C5=82=C4=85d=20436]=20=20Nowy:=20nieprzet=C5=82umaczone=20s=C5=82owo=20"Total"=20w=20raporcie=20tabelarycznym?=

(przy okazji, czy dwie spacje są tam potrzebne?)

może na https://bugzilla.mozilla.org/show_bug.cgi?id=110692 i
https://bugzilla.mozilla.org/show_bug.cgi?id=126266 będą jakieś przydatne
informacje (albo to moje pine nie lubi takich tematów)
Comment 4 Pawel Chmielowski 2005-03-25 20:10:25 CET
Zamykam, moj pine pokazuje teraz tematy prawidlowo. Roman otworz jesli nadal
masz z tym klopoty.

Note You need to log in before you can comment on or make changes to this bug.