Przejdź do:

Archiwum – August 2010

Aviary.pl, oficjalny polski zespół lokalizacyjny Mozilla.org ma przyjemność przedstawić lokalizację systemu śledzenia błędów Bugzilla w wersji 3.6.1.
Polskie pakiety lokalizacyjne można pobrać ze strony http://projects.aviary.pl/bugzilla/.

To wydanie rozwiązuje przede wszystkim dwa problemy związane z bezpieczeństwem. Szczegóły dostępne są w biuletynach bezpieczeństwa.

Ponadto naprawiono:

  • Korzystanie ze strony Zmień kolumny, mogło skutkować wyświetleniem strony w postaci zwykłego tekstu zamiast HTML (błąd 376044),
  • Skrypt install-module.pl, który obecnie umożliwia prawidłową instalację wymaganych modułów na nowych i starszych wersjach Perl (błędy 560318 i 560330),
  • Brak możliwości modyfikowania nazwy wartości pola (za pomocą strony Wartości pól) w przypadku, gdy dana wartość była ustawiona jako domyślna dla tego pola (błąd 561296),
  • Brak możliwości modyfikowania błędów w przypadku, jeśli błędy były oznaczone statusem NAPRAWIONY i miały otwarte błędy blokujące, a parametr noresolveonopenblockers został ustawiony. Założeniem tego parametru jest uniemożliwienie zmiany statusu błędu na NAPRAWIONY, a nie blokowanie możliwości modyfikowania błędów o tym statusie (błąd 565314),
  • Drobne problemy wywoływane przez Perl w wersji 5.12 (wyeliminowanie ostrzeżeń wyświetlanych przez tę wersję).

Dodano:

  • Możliwość korzystania z rozszerzeń zawierających tylko pliki tmpl (błąd 562551),
  • Możliwość aktualizacji Bugzilli 3.4 do wersji 3.6 dla użytkowników bazy danych Oracle (błąd 561379).

Pakiet lokalizacyjny przeznaczony jest dla wersji 3.6.1 oraz 3.6.

Aviary.pl, oficjalny polski zespół lokalizacyjny Mozilla.org ma przyjemność przedstawić lokalizację systemu śledzenia błędów Bugzilla w wersji 3.4.6 oraz 3.4.7.
Polskie pakiety lokalizacyjne można pobrać ze strony http://projects.aviary.pl/bugzilla/.

Najważniejsze nowości w wersji 3.4.6 to między innymi:

  • możliwość zgłaszania błędów przy pomocy uproszczonej wersji formularza
  • nowy wygląd strony głównej
  • ukrywanie adresów e-mail przed niezalogowanymi użytkownikami
  • krótsze adresy url wyszukiwania
  • większa wydajność mechanizmu wysyłania wiadomości e-mail poprzez możliwość ich kolejkowania
  • możliwość określenia strefy czasowej przez użytkownika
  • wyświetlanie pól dodatkowych w zależności od wartości innych pól
  • wyświetlanie zawartości list wyboru pól dodatkowych w zależności od wartości innych pól
  • pole błędu  –  Zobacz też
  • nowy typ pola dodatkowego – Identyfikator błędu
  • nowy interfejs umożliwiający zmianę kolejności kolumn wyświetlanych na listach błędów
  • i wiele, wiele innych.

Natomiast wydanie 3.4.7 rozwiązuje problem z bezpieczeństwem związany z funkcją śledzenia czasu pracy. Szczegóły dostępne są w biuletynach bezpieczeństwa.

Naprawiono następujące błędy:

  • Utratę połączenia z bazą danych i zatrzymywanie wysyłania e-maili w przypadku bardzo długiego czasu wykonywania skryptu jobqueue.pl (błąd 538705).
  • Wyświetlanie niejasnego komunikatu o błędzie w trakcie logowania po zamianie hasła użytkownika (błąd 549814).
  • Występowanie awarii Bugzilli współpracującej z bazą danych PostgreSQL podczas próby usunięcia pola dodatkowego (błąd 557495 i 557686).
  • Zwiększono prędkość strony show_bug.cgi odpowiedzialnej za wyświetlanie/modyfikację błędów w przypadku, gdy błąd zawiera wiele komentarzy (błąd 498309).
  • Umożliwiono podczas wywoływania strony config.cgi dodawanie do jej adresu URL parametru ?flags=0, by nie wyświetlać danych dotyczących flag. Znacząco to przyśpiesza wyświetlanie strony config.cgi (błąd 553267).